DCloud_App_Array
DCloud_App_Array
  • 发布:2019-01-11 19:36
  • 更新:2019-02-27 10:52
  • 阅读:1479

iOS云打包提交Appstore提示“ERROR ITMS-90534: "Invalid Toolchain.”的问题

分类:HBuilderX

更新:此问题已过期。1月12日起已经恢复正常。
遇到无法上传Appstore的问题,请单独开贴。

以下内容已过期==========================
最近苹果提交Appstore验证机制的更新,导致使用XCode9.2版本生成的ipa会提示“ERROR ITMS-90534”错误。
目前HBuilder&HBuilderX大多数云端打包机使用的都是XCode9.2版本,从今天(2019.1.11)中午开始已经暂停了所有存在此问题的打包机。

由于减少了打包机,导致iOS云端打包排队比较严重,打包等待时间较长,请耐心等待(估计排队4个小时)。因为创建新的打包机对目前运行的打包机会产生影响,所以此问题可能会持续到周末,在此期间还请避免提交不必要的打包请求。

注意:碰到“ERROR ITMS-90534”问题的开发者需要重新提交云端打包才能解决,为了避免目前的阻塞,请错峰打包

由此给您带来不便,敬请谅解!

注:离线打包只要不使用XCode9.2就仍然可用。

4 关注 分享
bagih@qq.com 799968247@qq.com know565@qq.com 幸福摩天轮

要回复文章请先登录注册

DCloud_App_Array

DCloud_App_Array (作者)

回复 jianli: 请更新到HBuilderX1.6.0及以上版本,重新提交云端打包。
2019-02-27 10:52
jianli

jianli

Invalid Toolchain. Your app was built with an unsupported version of Xcode or SDK. If you plan to submit this build to the App Store, make sure you are using the GM version of Xcode 9 and the SDK for iOS 11, tvOS 11, watchOS 4, or macOS 10.13 or later. If you are using an Xcode beta version to test your app, make sure you are using the latest supported version. For more information about supported beta versions, view the TestFlight Release Notes (https://developer.apple.com/testflight/release-notes/).

我仍然遇到了这个问题,改怎么解决?
2019-02-26 17:33
旺旺小学酥

旺旺小学酥

SDK Version Issue - This app was built with the iOS 11.1 SDK. Starting March 2019, all iOS apps submitted to the App Store must be built with the iOS 12.1 SDK or later, included in Xcode 10.1 or later.
啥时候解决?老板催了。。
2019-02-26 16:01
silenty1981@aliyun.com

silenty1981@aliyun.com

可以了,感谢官方积极处理。另外在上传过程中有个SDK版本的警告:

SDK Version Issue - This app was built with the iOS 11.1 SDK. Starting March 2019, all iOS apps submitted to the App Store must be built with the iOS 12.1 SDK or later, included in Xcode 10.1 or later.

希望官方能注意到,并尽早处理。
2019-01-15 10:06
2411923851@qq.com

2411923851@qq.com

回复 DCloud_App_Array: appid:H58344D7A,用的appuploader
2019-01-14 11:41
DCloud_App_Array

DCloud_App_Array (作者)

回复 2411923851@qq.com: 1.提供下应用appid(manifest.json文件中的id字段值)?
2.确认是使用Application Loader提交的,版本号多少?
2019-01-14 11:37
2411923851@qq.com

2411923851@qq.com

Dear Developer,

We identified one or more issues with a recent submission for your app, "爱镯魔网络工厂". Please correct the following issues, then upload again.

Invalid Toolchain - Your app was built with an unsupported version of Xcode or SDK. If you plan to submit this build to the App Store, make sure you are using the GM version of Xcode 9 and the SDK for iOS 11, tvOS 11, watchOS 4, or macOS 10.13 or later. If you are using an Xcode beta version to test your app, make sure you are using the latest supported version. For more information about supported beta versions, view the TestFlight Release Notes (https://developer.apple.com/testflight/release-notes/).

Best regards,

The App Store Team
还是提交不了appstore,什么情况,求解决
2019-01-14 11:30
幸福摩天轮

幸福摩天轮

可以了,谢谢官方积极处理此事
2019-01-14 10:47
fengjiayong520@163.com

fengjiayong520@163.com

回复 fengjiayong520@163.com: 升级最新hx,云端出来的包,上传苹果商店还是有问题。id私发给你
2019-01-12 16:14
fengjiayong520@163.com

fengjiayong520@163.com

回复 DCloud_App_Array: 升级最新hx,再试试
2019-01-12 15:37
特洛伊

特洛伊

回复 特洛伊: 刚才问的时候本问题内容还没有更新,抱歉.... 现在明了了
2019-01-12 14:25
特洛伊

特洛伊

回复 DCloud_App_Array: 我也碰到了同样的问题,请问怎么解决呢
2019-01-12 14:21
DCloud_App_Array

DCloud_App_Array (作者)

回复 fengjiayong520@163.com: 提供下你应用的appid(manifest.json文件中的id字段值)
2019-01-12 13:29
fengjiayong520@163.com

fengjiayong520@163.com

已经修复了吗? 我刚打包还是不行
2019-01-12 12:55
know565@qq.com

know565@qq.com

第一次提交store让我赶上了, 不过hb解决得蛮迅速,
2019-01-12 12:36
zhengling_966@163.com

zhengling_966@163.com

可以了,谢谢官方积极处理此事。
2019-01-12 10:43