1409278235@qq.com
1409278235@qq.com
  • 发布:2020-03-27 19:57
  • 更新:2020-03-31 00:00
  • 阅读:170

ipad ios13.3.1本地选项卡点击没有正常跳转

分类:wap2app

[问题]

公司的一个webapp最近需要更新一些新功能,上架审核苹果那边使用ipad 13.3.1审核,本地选项卡点了不跳转,只是切换选中效果。
本地选项卡是参考官方文档做的本地选项卡,经测试,安卓系统、iphone ios13.3.1、ipad ios12正常使用,唯独ipad ios13出现上述情况。

iphone测试是没有问题的,能否上架审核设置为仅支持iphone(目前有正式版本在appstore上),让审核人员用iphone审核

IDE运行环境说明

HBuilderX

[iOS版本号]
iOS3.3.1

[代码](client_index.html)

    new TabBar({    
        list: [{    
            url: "具体链接",    
            text: "首页",    
            iconPath: 'images/01B.png',    
            selectedIconPath: 'images/01.png'    
        }, {    
            url: "具体链接",    
            text: "好物晒单",    
            iconPath: 'images/02B.png',   
            selectedIconPath: 'images/02.png'    
        }, {    
            url: "具体链接",    
            text: "店长权益",    
            iconPath: 'images/05B.png',  
            selectedIconPath: 'images/05.png'    
        }, {    
            url: "具体链接",    
            text: "超级搜索",    
            iconPath: 'images/03B.png',  
            selectedIconPath: 'images/03.png'    
        },  
        {  
            url: "具体链接",    
            text: "个人中心",    
            iconPath: 'images/04B.png',  
            selectedIconPath: 'images/04.png'    
        }  
        ]    
    });  

[代码](sitemap.json)

"webviewParameter": {  
                "titleNView": false,  
                "statusbar": {  
                    "background": "#f7f7f7"  
                },  
                "tabBar": {  
                    "height": "50px",  
                    "list": [    
                        {    
                            "url": "具体链接"   
                        }, {    
                            "url": "具体链接"    
                        }, {    
                            "url": "具体链接"   
                        }, {    
                            "url": "具体链接"     
                        }, {    
                            "url": "具体链接"    
                        }  
                    ]    
                }   

            }  
        },

有没有人遇到过或者知道是啥问题的

2020-03-27 19:57 负责人:无 分享
已邀请:
8925683@qq.com

8925683@qq.com

有遇到这样问题
第一次加截会出现
当APP退出后再次打开就没问题了。

  • 1409278235@qq.com (作者)

    我的好像也是第一次打开这样,请问你有没有找出是啥问题?因为我们要上架appstore,所以这个问题很严重,审核过不了。

    2020-03-31 21:34

  • 8925683@qq.com

    回复 1409278235@qq.com: 暂时还没有解决方案,我把 WKWebview 改成 UIWebview 一切正常了,但 苹果4月份就不接受 UIWebview 的了,唉,官方好像放弃了 mui 框架,用官方的 hello mui 在最新的 iPad 打开也不正常了

    2020-03-31 23:44

要回复问题请先登录注册