enderX
enderX
  • 发布:2022-02-10 10:51
  • 更新:2022-02-10 12:30
  • 阅读:374

【报Bug】cli 3.3.3 版本开始,当 nvue 组件或其引用组件 style 标签有 lang="scss" 属性时,抛错并退出运行

分类:uni-app

产品分类: uniapp/App

PC开发环境操作系统: Mac

PC开发环境操作系统版本号: 11.6

HBuilderX类型: 正式

HBuilderX版本号: 3.3.10

手机系统: 全部

手机机型: x

页面类型: nvue

vue版本: vue2

nvue编译模式: fast

打包方式: 云端

项目创建方式: CLI

CLI版本号: 3.3.3 +

测试过的手机:

null

操作步骤:

预期结果:

正常运行

实际结果:

rt

bug描述:

rt。单开一个吧,原先那个回复的好长了。

依赖版本:

{  
    "node-sass": "^4.14.1",  
    "sass-loader": "^7.3.1",  
}

执行 npm run dev:app-plusnpm run build:app-plus
终端抛出的错误(使用的 v3.3.9):

Start to compile the current project to the app-plus platform...Module build failed (from ./node_modules/@dcloudio/vue-cli-plugin-uni/packages/sass-loader/dist/cjs.js):  
ValidationError: Invalid options object. Sass Loader has been initialized using an options object that does not match the API schema.  
 - options has an unknown property 'outputStyle'. These properties are valid:  
   object { implementation?, sassOptions?, prependData?, sourceMap?, webpackImporter?, nvue? }  
    at validate (/Users/es/Documents/HBuilderProjects/test3.3.10/node_modules/@dcloudio/vue-cli-plugin-uni/packages/sass-loader/node_modules/schema-utils/dist/validate.js:96:11)  
    at Object.loader (/Users/es/Documents/HBuilderProjects/test3.3.10/node_modules/@dcloudio/vue-cli-plugin-uni/packages/sass-loader/dist/index.js:38:28)

实际上,使用 3.3.3 之前的版本时,跟 sass 处理器的版本并没有什么关系;
使用 3.3.3 及之后的版本时,如果使用更高版本的 sass 处理器,会抛出如下错误:

Syntax Error: Error: Node Sass version 5.0.0 is incompatible with ^4.0.0.

此时对应的 loader 版本:

{  
    "node-sass": "^5.0.0",  
    "sass-loader": "^10.2.0",  
}
2022-02-10 10:51 负责人:DCloud_UNI_GSQ 分享
已邀请:
DCloud_UNI_GSQ

DCloud_UNI_GSQ

yarn add sass-loader@^8

  • enderX (作者)

    ok


    {  
    "node-sass": "^4.14.1",
    "sass-loader": "^8.0.2",
    }

    2022-02-10 13:55

要回复问题请先登录注册