1***@qq.com
1***@qq.com
  • 发布:2022-04-27 17:16
  • 更新:2022-09-09 15:59
  • 阅读:877

新建uniapp vue3版本项目,使用picker 报错

分类:HBuilderX

HBuilder 新增一个vue3的项目后使用picker这个组件,选择完成后会报这个错误

Uncaught TypeError: Cannot redefine property: instance
at Function.defineProperty ()
at wrapperH5WxsEvent (uni-h5.es.js:1205)
at $nne (uni-h5.es.js:1234)
at HTMLDivElement.invoker (vue.runtime.esm.js:9533)

使用的是官方给的例子。

2022-04-27 17:16 负责人:无 分享
已邀请:
程序小菜鸟

程序小菜鸟 - 不会外语的程序员不是好销售

遇到一模一样的问题。在 vant 的input组件上点击选中就出这个问题。

非专业键盘侠

非专业键盘侠

这不是picker的问题吧。我用elementPlus,点击按钮都是这个,还特意切换到上个版本,发现上个版本没有问题。
坐等新版本更新

非专业键盘侠

非专业键盘侠

3.4.12表示已经修复

DCloud_UNI_Anne

DCloud_UNI_Anne

已记录此问题后续优化,已加分,感谢您的反馈!

DCloud_UNI_LXH

DCloud_UNI_LXH

预计下版修复

9***@qq.com

9***@qq.com

我去同遇到了,我这个是使用上传不行

包拯

包拯 - 包青天

同样问题

7***@qq.com

7***@qq.com

希望官方能尽快解决哦,我使用element-plus的el-dialog每次点击事件发生也会有这个报错,但好像其他影响暂时没有

9***@qq.com

9***@qq.com

同样的问题,请求解决

非专业键盘侠

非专业键盘侠

目前3.4.9版本并没有解决这个问题。web页面,每次点击个按钮什么的就飘红报错,控制台简直不能看,闹心

蜡笔小鑫

蜡笔小鑫

同样的问题,等待解决

DCloud_UNI_LXH

DCloud_UNI_LXH

alpha 3.4.10 已修复

  • 7***@qq.com

    是这个版本吗

    3.0.0-alpha-3041020220512001

    为啥我会报新的错误?导致页面白屏

    Uncaught TypeError: Cannot read properties of undefined (reading '$page') at new ServiceMediaQueryObserver

    2022-05-24 12:09

2***@qq.com

2***@qq.com

还是遇见了这个错误

  • DCloud_UNI_LXH

    是在什么环境下创建运行的?

    2022-06-02 14:50

f***@163.com

f***@163.com

并没有解决这个问题啊 正式版3.4.15.20220610
H5下 picker 点击确定 报错:

Uncaught TypeError: Cannot redefine property: instance
at Function.defineProperty ()
at wrapperH5WxsEvent (uni-h5.es.js:1205:12)
at $nne (uni-h5.es.js:1234:14)
at HTMLDivElement.invoker (vue.runtime.esm.js:9533:19)

  • DCloud_UNI_LXH

    使用正式版 3.4.15.20220610 ,运行到 H5 已经没有这个报错了啊

    2022-06-27 18:34

Anet

Anet

编辑器版本:3.6.1.20220907-alpha

Vue版本:Vue3

项目创建方式:vue-cli

鼠标滚动时报错

  • DCloud_UNI_LXH

    问题修复过,把 vue3 编译插件卸载重装

    2022-09-09 15:12

  • Anet

    回复 DCloud_UNI_LXH: vue3编译器卸载了,重新安装,重新运行,还是不行 现在用的是 vue3(3.6.1-2022090720)

    2022-09-09 15:17

  • DCloud_UNI_LXH

    回复 Anet: 我测试的就是这个,看看你安装的 vue3 编译器版本是 3.6.1 吗?

    2022-09-09 15:18

  • Anet

    回复 DCloud_UNI_LXH: vue3 编译器版本是 3.6.1-2022090720的

    2022-09-09 15:21

  • DCloud_UNI_LXH

    回复 Anet: 把我最新新增的附件替换至路径重新运行看看

    2022-09-09 16:07

DCloud_UNI_LXH

DCloud_UNI_LXH

替换附件至 hx 根目录\plugins\uniapp-cli-vite\node_modules\@dcloudio\uni-h5\dist

  • Anet

    替换之后,重启编辑器,选择内置浏览器运行,还是不行,还是报错了

    2022-09-09 16:21

  • DCloud_UNI_LXH

    回复 Anet: 哦哦哦,你是 cli 是吧,不好意思没有看清。那你更新下 cli 版本,或者把附件替换至 项目根目录\node_modules\@dcloudio\uni-h5\dist

    2022-09-09 16:26

  • Anet

    回复 DCloud_UNI_LXH: Uncaught SyntaxError: The requested module '/node_modules/@dcloudio/uni-shared/dist/uni-shared.es.js' does not provide an export named 'ON_NAVIGATION_BAR_CHANGE' (at uni-h5.es.js:3:772) 替换之后整个页面都不渲染了,还报了这个错误

    2022-09-09 16:52

  • DCloud_UNI_LXH

    回复 Anet: 那你把 cli 整体升级到 3.0.0-alpha-3060120220907002

    2022-09-09 17:11

  • Anet

    回复 DCloud_UNI_LXH:弱弱得问一句,升级命令是啥?

    2022-09-09 17:24

  • DCloud_UNI_LXH

    回复 Anet: https://uniapp.dcloud.net.cn/quickstart-cli.html#cliversion

    2022-09-09 17:31

  • Anet

    回复 DCloud_UNI_LXH: 执行 npx @dcloudio/uvm 3.0.0-alpha-3060120220907002 吗?执行不了,报错了

    2022-09-09 17:36

要回复问题请先登录注册