2***@qq.com
2***@qq.com
  • 发布:2023-06-02 14:45
  • 更新:2023-11-28 16:52
  • 阅读:886

使用vscode搭建uniapp应用,安装使用pinia,出现版本不兼容

分类:uni-app

在vscode中创建一个uniapp项目,安装导入pinia,出现图片中的错误,自己尝试解决错误,说是vue3和pinia的版本不兼容,尝试更迭版本,错误依然存在

2023-06-02 14:45 负责人:DCloud_UNI_OttoJi 分享
已邀请:

最佳回复

DCloud_UNI_OttoJi

DCloud_UNI_OttoJi - 日常回复 uni-app/x 问题,如果艾特我没看到,请主动私信

pinia v2.1 需要高版本的 vue 支持,目前鼓励先锁定 pinia: ~2.0 。相关讨论在 https://ask.dcloud.net.cn/question/169971

piaoyi_UI

piaoyi_UI - 【插件开发】【专治疑难杂症】【多款插件已上架:https://ext.dcloud.net.cn/publisher?id=193663(微信搜索飘逸科技UI小程序直接体验)】【骗子请绕道】问题咨询请加QQ群:120594820,代表作灵感实用工具小程序

vscode怎么创建的uniapp项目?用HBuilder X创建啊

  • 2***@qq.com (作者)

    用命令行创建的,HBuilderX不好用

    2023-06-02 14:55

银河搬运工

银河搬运工 - 每天的砖都烫手

直接把pinia版本写死,我成功了

"pinia": "2.0.3",
  • 1***@gmail.com

    npm install pinia@2.0.3 --save --legacy-peer-deps

    参考了你的 这样就成功了

    2023-08-12 17:18

要回复问题请先登录注册