金辰
金辰
  • 发布:2020-04-29 10:33
  • 更新:2024-01-23 15:05
  • 阅读:7587

WGT安装包中manifest.json文件的version版本不匹配

分类:HBuilderX

看到社区有旧的相关帖子,但无一能解决问题。

首先, 可以正常下载wgt, 可以启动更新安装程序,但立刻报“安装wgt文件失败[-1205]:WGT安装包中manifest.json文件的version版本不匹配”
其次, 程序实际只修改了一个js文件夹中config.js的一个变量从0变成了1,没有任何其他基础包变更;
再有, manifest.json当中
"version" : {
"name" : "1.0.4", /应用版本名称/
"code" : 85
},
分别变成
"version" : {
"name" : "1.0.5", /应用版本名称/
"code" : 86
},

"version" : {
"name" : "1.0.5", /应用版本名称/
"code" : 85
},
均提示上述错误信息。
最后, 确保manifest.json当中其他一切信息(当然包括ID)都没有任何变化。 也确保了手机下载的wgt就是最新打包的这个文件,可就是无论如何都会提示:
安装wgt文件失败[-1205]:WGT安装包中manifest.json文件的version版本不匹配

求解求解

2020-04-29 10:33 负责人:无 分享
已邀请:
f***@126.com

f***@126.com

我在android app更新上也出现这个问题了,下载wget解压后也发现version版本是没有问题的。
plus.runtime.install(download.filename, {force:true}, function() {
....
})
我添加了force:true 后,安装正常了。基本可以肯定是uniapp的bug。。。

1***@163.com

1***@163.com

同样的问题 一年多了 还是没有结局方案吗

  • 931473809

    你好,我的应用一直报这个错误 不知道怎么解决 你的解决了吗

    2021-11-18 11:13

开车去澳洲

开车去澳洲

我发现也是这样

  • 931473809

    请问这个问题解决了吗

    2021-11-19 15:17

w***@163.com

w***@163.com

请问这个问题解决了吗

  • 931473809

    请问这个问题解决了吗

    2021-11-19 15:17

1***@qq.com

1***@qq.com

我也是这样,请问要如何解决?

8***@qq.com

8***@qq.com - 飞雄

force:true 那是强制安装忽略的版本号的肯定可以的。

force: (Boolean 类型 )是否强制安装

true表示强制安装,不进行版本号的校验;false则需要版本号校验,如果将要安装应用的版本号不高于现有应用的版本号则终止安装,并返回安装失败。 仅安装wgt和wgtu时生效,默认值 false。

  • 931473809

    有什么好的解决方法吗

    2021-11-19 14:34

3***@qq.com

3***@qq.com - 和不可忘记

请问如何解决,现在还是这样

  • 931473809

    你好,我的应用一直报这个错误 不知道怎么解决 你的解决了吗

    2021-11-19 14:34

  • q***@163.com

    回复 931473809: 请问解决了吗

    2023-11-08 09:53

931473809

931473809

请问这个问题解决了吗

  • 浅樱

    同问

    2021-12-24 16:14

b***@qq.com

b***@qq.com

都2023了,还报这个错,uniapp 的工程师行不行

3***@qq.com

3***@qq.com

2024年了,同样的问题。

要回复问题请先登录注册