617903352@qq.com
617903352@qq.com
  • 发布:2019-08-20 11:37
  • 更新:2019-11-18 20:04
  • 阅读:1334

最新版HbuilderX 2.2.2 项目中使用原生插件,自定义调试的时候报“当前运行的基座不包含原生插件[Zhiqu-ySKAuth]”

分类:uni-app

问题

做uni-app项目的时候,需要使用到人脸识别认证技术。所以使用原生插件[Zhiqu-ySKAuth]。在我项目1.1.9的时候,打包可以正常使用。自从跟新了Hbuilderx为2.2.2的时候,我自定义基座运行调试的时候,报“当前运行的基座不包含原生插件[Zhiqu-ySKAuth]”错误。

打包流程

当前HbuilderX版本:

购买原生插件:

勾选原生插件:

自定义基座:

真机调试时:

疑惑

我明明有勾选,却提示我“当前运行的基座不包含原生插件[Zhiqu-ySKAuth],请在manifest中配置该插件,重新制作包括该原生插件的自定义运行基座”。

求救

有谁能来救救我,这项目很急。

2019-08-20 11:37 分享
已邀请:

最佳回复

DCloud_iOS_XHY

DCloud_iOS_XHY

此问题打包机已修复,重提提交自定义基座打包即可

  • 617903352@qq.com (作者)

    好的,我试试

    2019-08-27 15:22

  • zrl_820@163.com

    回复 617903352@qq.com: 我升级到最新版本还是不行

    2019-08-28 10:53

  • 984505383@qq.com

    最新版的alpha ,自定义基座打包还是不行,一样的错误呢。。

    2019-08-28 12:09

  • zrl_820@163.com

    哪个版本是可以的

    2019-08-28 14:16

  • 133490326@qq.com

    官方解决一下这个BUG


    https://ask.dcloud.net.cn/question/75006

    2019-08-30 10:38

  • jy00052438@163.com

    android的可以了,但是ios插件一样有这个问题,ios插件还是提示"当前运行的基座不包含原生插件[zdbaichuan],请在manifest中配置该插件,重新制作包括该原生插件的自定义运行基座"

    2019-09-10 13:59

  • jy00052438@163.com

    补充一下,ios插件有100M,是用APP大小超限的打自定义基座。

    2019-09-10 14:07

  • 慢慢成长

    还是不行啊,无论安卓还是ios调用SDK都还是这个错误,有进度吗?几时更新下一个版本

    2019-09-12 14:29

869211846@qq.com
984505383@qq.com

984505383@qq.com - 比较懒

遇到相同问题,解决了吗大佬,求指导。

2407439@qq.com

2407439@qq.com

我也是这个问题,两天前就把程序发给官方了

DCloud_iOS_XHY

DCloud_iOS_XHY

此问题正在排查,解决了会在帖子回复,注意消息通知

yind0519@sina.com

yind0519@sina.com

解决了吗

xiali@leiit.net

xiali@leiit.net

+1,解决了吗

gzfgeh@qq.com

gzfgeh@qq.com - 个人承接PHP、uniapp项目,有案例,联系QQ 305475422

解决了吗?

1176236196@qq.com

1176236196@qq.com

解决了吗?我也是这个问题,用最新的2.27版本的

  • heydongtech@heydong.cn

    你现在还有 不包含原生插件 这个问题吗? 解决了吗?我的是2.3.3,也是这个问题

    2019-09-29 10:43

2390860850@qq.com

2390860850@qq.com

真机上可以,模拟器不行,不知咋回事

tiandiweb@qq.com

tiandiweb@qq.com

我也是这个问题,已经10月22号了,我和楼主的 情况一样。
HX2.3.6啊

545472882@qq.com

545472882@qq.com

哎 还是没解决

260115678@qq.com

260115678@qq.com

我的安卓的在manifest.json可视化里面可以配置对应的包,但是在编译的时候说是"[JS Framework] 当前运行的基座不包含原生插件[NettyPush],请在manifest中配置该插件,重新制作包括该原生插件的自定义运行基座",这个自定义的原生插件是不能用的吗?

要回复问题请先登录注册