1***@qq.com
1***@qq.com
  • 发布:2019-12-08 14:54
  • 更新:2022-02-14 17:46
  • 阅读:2550

【报Bug】uni-app 在H5端的rpx单位转换出现乱码

分类:uni-app

详细问题描述

(DCloud产品不会有明显的bug,所以你遇到的问题大都是在特定环境下才能重现的问题,请仔细描述你的环境和重现方式,否则DCloud很难排查解决你的问题)

[内容]

重现步骤

[步骤]
使用vue-cli安装uni-app的脚手架,然后选择默认模板
安装了node-sass 和 sass-loader之后
yarn run dev:h5

打开浏览器,样式出现错乱

[结果]
发现所有的rpx--> 单位的转换出现乱码

[期望]
rpx --> 转换正确

[如果语言难以表述清晰,拍一个视频或截图,有图有真相]
见附件

IDE运行环境说明

[HBuilder 或 HBuilderX。如果你用其他工具开发uni-app,也需要在此说明]

[IDE版本号]
2.4.2.20191115

[windows版本号]

[mac版本号]
10.14.3

uni-app运行环境说明

[运行端是h5或app或某个小程序?]
h5

[运行端版本号]

[项目是cli创建的还是HBuilderX创建的?如果是cli创建的,请更新到最新版cli再试]
cli创建的

[编译模式是老模板模式还是新的自定义组件模式?]

App运行环境说明

[Android版本号]

[iOS版本号]

[手机型号]

[模拟器型号]

附件

[IDE问题请提供HBuilderX运行日志。菜单帮助-查看运行日志,点右键打开文件所在目录,将log文件压缩成zip包上传]

[App问题请提供可重现问题的代码片段,你补充的细一点,问题就解决的快一点]

[App安装包或H5地址]

[可重现代码片段]

联系方式

[QQ]
1844209986

2019-12-08 14:54 负责人:无 分享
已邀请:
DCloud_UNI_GSQ

DCloud_UNI_GSQ

将uni相关依赖更新到 2.0.0-24220191115011 版本及以上即可。
使用的uni相关依赖在 2.0.0-24220191115006 版本及以下的请将@vue/cli-service依赖安装为4.0以下版本

  • 957

    @vue/cli-service 是在 4.0版本以下的,还不行 求解

    2019-12-18 19:39

  • 3***@qq.com

    你们这是啥情况啊 这么久不给个回馈吗 更新过npm的样式都乱了

    2019-12-18 20:21

  • zhanqi

    "@vue/cli-plugin-babel": "^4.1.1",也会出现找不到foo.js的错误

    2019-12-18 21:01

  • CNStone

    如何操作:

    “将uni相关依赖更新到 2.0.0-24220191115011 版本及以上即可。

    使用的uni相关依赖在 2.0.0-24220191115006 版本及以下的请将@vue/cli-service依赖安装为4.0以下版本”

    谢谢!

    2021-06-21 10:35

wwp66650

wwp66650

我也遇到了

sorke

sorke

我也遇到了了,脚手架的版本好像低于HX客户端版。在HBuilderX下没问题,脚手架创建就出现
如图:

  • sorke

    先去尝试4.0以下看看

    2019-12-10 16:47

  • sorke

    降低版本成功运行,谢谢

    2019-12-10 17:33

sonicsunsky

sonicsunsky

我也遇到了,改下@vue/cli-service就好了吗?

957

957 - 三某人

@vue/cli-service 是在 4.0版本以下的,还不行 求解

DCloud_UNI_GSQ

DCloud_UNI_GSQ

使用的uni相关依赖在 2.0.0-2422019111506 版本及以下的请将@vue/cli-service依赖安装为4.0以下版本

clfeng

clfeng

H5场景:
脚手架改成以下版本还是不行:
"@vue/cli-service": "3.12.1",

在业务的vue文件里写的单位会转成px;
但是uni.scss文件里的则不会转换

清茶涩

清茶涩

啥情况,都五百年了,今天用cli创建了项目还是不行,rpx都没转,浏览器不认识

要回复问题请先登录注册