兮
  • 发布:2020-05-14 11:10
  • 更新:2020-05-19 02:37
  • 阅读:937

云函数公共模块提示 npm install 执行失败

分类:uniCloud

公共模块common_ali上传失败。失败原因:npm install 执行失败。请检查node执行环境。 例:尝试安装npm并设置环境变量后,再次操作。

公共模块安装依赖包,例 express

然后上传就失败;

问:
云函数不能使用npm 安装依赖吗???

2020-05-14 11:10 负责人:无 分享
已邀请:
a***@tudiju.com

a***@tudiju.com

解决了 用管理员方式运行HX 搞定

  • 1***@qq.com

    醉了 mac用管理员模式运行 上传的时候直接就闪退了

    2020-07-13 10:33

  • 迈远科技

    正解!!

    2021-04-13 11:21

DCloud_UNI_WYQ

DCloud_UNI_WYQ

自己本地使用npm install安装这些依赖的时候能装上不?使用的是npm源还是淘宝源

  • 6***@qq.com

    淘宝源,本地可以安装

    2020-06-11 13:58

DCloud_HB_WDL

DCloud_HB_WDL

HBuilderX版本号多少? 如果本地没有安装node, 安装node环境后再重试下。

z***@163.com

z***@163.com

我也遇到这个问题,
HBuilderX版本:2.6.16.20200424

DCloud_UNI_WYQ

DCloud_UNI_WYQ

如果在HBuilderX内配置了node路径和npm路径就删掉试试,如果没配置就配上试试

a***@tudiju.com

a***@tudiju.com

2.7.4 一样出现这个问题

[uni-pay示例] 02:32:17.086 [阿里云:unipayceshi]公共模块config上传失败。失败原因:npm install 执行失败。请检查node执行环境。 例:尝试安装npm并设置环境变量后,再次操作。

要回复问题请先登录注册