z***@yeah.net
z***@yeah.net
  • 发布:2020-08-20 14:57
  • 更新:2021-09-02 18:29
  • 阅读:756

uniMPSDK-release和lib.5plus.base-release不能同时存在的问题

分类:uni小程序sdk

我用Android studio进行原生开发的时候,项目里同时添加uniMPSDK-release.aar和lib.5plus.base-release.aar包,编译的时候,会报错,提示com.dcloud.android.annotation.IntDef,uniapp-release.aar和uniapp-v8-release.aar也会报冲突,所以uni小程序和App离线打包只能实现一个功能,不能同时实现,是吗?或者有什么方案可以同时实现?

2020-08-20 14:57 负责人:无 分享
已邀请:

最佳回复

DCloud_Android_ST

DCloud_Android_ST

是的 两者不能共存

  • z***@yeah.net (作者)

    好的,谢谢

    2020-08-25 08:40

  • 暖心xia

    那怎么才能调用到uniMPSDK的方法

    2020-10-18 20:34

l***@mail.com

l***@mail.com

为什么 要这样 设计

原生安卓APP集成UNIAPP小程序 还要集成H5商城咋办 呀
下个 版本 会共存吗

  • 暖心xia

    同问,都是泪

    2020-10-18 20:34

l***@mail.com

l***@mail.com

lib.5plus.base-release 这个 有开源 版本 吗

9***@qq.com

9***@qq.com

作者,你说的问题,之后有解决方案吗,我现在也遇到这个问题

  • z***@yeah.net (作者)

    不知道,我放弃这个问题了,看样子现在还没解决

    2021-09-06 14:32

要回复问题请先登录注册