enderX
enderX
  • 发布:2021-08-26 19:33
  • 更新:2022-02-28 09:59
  • 阅读:1790

【报Bug】升级 cli 2.0.0-31920210709003,运行报错 Syntax Error: SassError: expected selector.

分类:uni-app

产品分类: uniapp/App

PC开发环境操作系统: Windows

PC开发环境操作系统版本号: win11

手机系统: Android

手机系统版本号: Android 11

手机厂商: -

手机机型: -

页面类型: vue

打包方式: 云端

项目创建方式: CLI

CLI版本号: ^2.0.0-31920210709003

操作步骤:

-

预期结果:

-

实际结果:

-

bug描述:

跟什么渠道发行方式没关系,全端运行报错。

Syntax Error: SassError: expected selector.

94 │ /deep/ .rich-text{
│ ^

src\pages\member\balance\detail.vue 94:1 root stylesheet

深度选择器替换为 ::v-deep 时不报错。
hx 最新版不报错。

2021-08-26 19:33 负责人:无 分享
已邀请:
maozai

maozai - 小程序开发者

我也遇到了

  • enderX (作者)

    最新版本的sass-loader的问题,全部替换成 ::v-deep 就可以了,这也是 vue 官方目前推荐的写法

    2022-02-28 15:14

  • maozai

    回复 enderX: 好的,谢谢,看你的帖子已经改了

    2022-03-02 17:56

要回复问题请先登录注册