machi的奶茶
machi的奶茶
  • 发布:2023-05-08 00:49
  • 更新:2023-05-08 16:12
  • 阅读:375

提交发布时在iOS 16.4.1版本,被告知应用启动时崩溃了

分类:uni-app

Hello,

The issues we previously identified still need your attention.

If you have any questions, we are here to help. Reply to this message in App Store Connect and let us know.

Guideline 2.1 - Performance - App Completeness

We were unable to review your app as it crashed on launch. We have attached detailed crash logs to help troubleshoot this issue.

Review device details:

  • Device type: iPhone
  • OS version: iOS 16.4.1

Next Steps

To address the crash in your app, follow these steps:

  1. Fully symbolicate the crash report. See Adding Identifiable Symbol Names to a Crash Report for an explanation of the symbolication process.
  2. Match the crash report to a common pattern. Based on the pattern, take specific actions to further investigate the crash. See Identifying the Cause of Common Crashes.
  3. Test your app on a device to ensure that it now runs as expected.
  4. Once you’ve addressed the crash, create and submit a new build to the App Store for review.

Resources

For additional information on crash reports, see Diagnosing Issues Using Crash Reports and Device Logs.

iOS App 1.6.6App 版本
拒绝原因:
2.1.0 Performance: App Completeness


应用在16.3.1及之前使用是正常,也没官方说遇到的那种启动就崩溃。因为电脑macOS系统版本问题(导致XCode创建iOS的simulators无法配置至16.4版本或更高),所以暂时无法测试验证该官方遇到的崩溃问题。

想先问问 在iOS 16.4及以上版本中,有什么新特性需要我们的应用去适配?

2023-05-08 00:49 负责人:DCloud_iOS_WZT 分享
已邀请:
DCloud_iOS_WZT

DCloud_iOS_WZT

你自己离线用Pod集成了快手?

  • machi的奶茶 (作者)

    这个不确定云打包时是否勾选了,但应用并没有使用到。


    为此,我将再次云打包,确定没有勾选任何广告SDK选项,进行提交至AppStore,等待反馈结果。

    2023-05-10 19:31

DCloud_iOS_WZT

DCloud_iOS_WZT

你云打包我看下 感觉不是16.4.1的问题 应该是有些情况下你的应用会crash 但是你没测试出来

  • machi的奶茶 (作者)

    1、使用截止现在的最新版本(3.7.11.20230427)进行了云打包;

    2、未勾选任何广告SDK选项。

    https://ide.dcloud.net.cn/build/download/63feb7b0-ef25-11ed-8495-9d12a0ef7e8a

    2023-05-10 19:32

要回复问题请先登录注册