z***@lettered.cn
z***@lettered.cn
  • 发布:2023-06-03 00:32
  • 更新:2023-06-26 14:05
  • 阅读:633

想了解下最新打包的问题,相关UTS的

分类:uni-app


我写了个插件,带有XXpermission的,今天更新包云打包报错了,提示是xxpermission冲突了。

想问问官方是不是你们的问题,我是不是可以在我的插件内移除这个xxpermission了?

打包错误:https://ide.dcloud.net.cn/build/errorLog/10810b50-015f-11ee-a0eb-e3eb908c0fdc

摘要:

FAILURE: Build failed with an exception.

  • What went wrong:
    Execution failed for task ':app:checkReleaseDuplicateClasses'.

    A failure occurred while executing com.android.build.gradle.internal.tasks.CheckDuplicatesRunnable
    Duplicate class com.hjq.permissions.AndroidVersion found in modules jetified-XXPermissions-16.2-runtime (com.github.getActivity:XXPermissions:16.2) and jetified-utsplugin-release-runtime (utsplugin-release.aar)

我去下载新版,存在这个utsplugin了,里面确实带了

我想官方什么时候处理下这个情况呀,谁知道你们用了哪些包,我们可以不再引入,或者你们做个处理过滤掉我们的呀

2023-06-03 00:32 负责人:无 分享
已邀请:
DCloud_App_Array

DCloud_App_Array

问题已确认,新版本会将XXpermission作为默认内置依赖,并调整为仓储依赖。
请将插件使用的XXpermission也调整为仓储依赖,避免与内置的XXpermission依赖冲突。

  • 自学成才

    什么时候能修复呢?我的APP现在都无法打包,无法正常更新市场版本

    2023-06-07 17:55

  • z***@lettered.cn (作者)

    回复 自学成才: 自己写插件的话就移除依赖,不然的话就反馈开发者等更新咯

    2023-06-12 17:43

k***@163.com

k***@163.com - 1

+1,我用的原生插件也是报这个错,之前五月初的时候没有问题,今天打自定义基座就是这个错,而且这个原生插件是花钱买的555
https://ide.dcloud.net.cn/build/errorLog/514c8a40-0515-11ee-adc4-4f4ed6a62c46

  • DCloud_App_Array

    目前自定义基座确实会有这个冲突(为了支持uts插件),正式打包不会存在问题,原生会尽快调整为仓储依赖。

    请跟插件作者联系下,调整插件也使用仓储依赖

    2023-06-09 12:00

  • z***@lettered.cn (作者)

    联系开发者处理吧,我自己都把依赖移出了

    2023-06-12 17:42

用户7810

用户7810

我打包ios也报错了(HBuilder X 3.8.4 -alpha)

Error code = -5000  
Error message:  
UTS plugin extapi/uni-extAPI compile error!  

## extapi/uni-extAPI  

Ld [PackagePath]/extapi/build/Release-iphoneos/DCloudUTSExtAPI.framework/DCloudUTSExtAPI normal (in target 'DCloudUTSExtAPI' from project 'UTS')
  • z***@lettered.cn (作者)

    你这个是插件编译是吧,我那是插件里的依赖冲突了

    2023-06-03 08:20

  • DCloud_App_Array

    请提供云端打包错误日志链接地址

    2023-06-05 11:07

w***@qq.com

w***@qq.com

同样的问题,赶紧处理一下吧,不然得降级HbuilderX了。错误日志链接https://ide.dcloud.net.cn/build/errorLog/f6f88e20-13c7-11ee-8cd0-21649bd009fc

  • z***@lettered.cn (作者)

    无语了,月底我看依赖冲突然后刚移除掉正常打包。然后前两天我打新包发现又没得这个依赖了,难过啊

    2023-06-26 15:03

  • z***@lettered.cn (作者)

    想要不冲突,就得升级3.8.5版本的,这个版本调整为远程依赖不会冲突了

    2023-06-26 15:06

  • w***@qq.com

    回复 z***@lettered.cn: 3.8.5不是还没发布

    2023-06-26 15:17

  • DCloud_App_Array

    回复 w***@qq.com: 正式版本已经发3.8.7了

    2023-07-04 12:16

要回复问题请先登录注册