1***@qq.com
1***@qq.com
  • 发布:2019-01-03 11:28
  • 更新:2019-01-03 17:10
  • 阅读:1494

hbuilder开的应用,用uni-app重写后发到苹果应用因设备支持问题无法通过

分类:uni-app

之前通过hbuilder做的应用,现在用uni-app重写的,上传到应用商店,发过来这封邮件,构建版本不出现。

邮件内容:

亲爱的开发者,
我们确定了您的应用最近发布的一个或多个问题,“xxxxx”。请更正以下问题,然后重新上传。

此捆绑包不支持先前应用版本支持的一个或多个设备。您的应用更新必须继续支持以前支持的所有设备。您使用Targeted Device Family构建设置在Xcode中声明支持的设备。有关其他信息,请参阅QA1623:https://developer.apple.com/library/ios/#qa/qa1623/_index.html

1.添加设备支持为universal
"ios" : {
"devices" : "universal",
....
},
2.把hbuilder项目的icon,splashscreen复制过来

通过上面两种方法,用application loader上传后,构建版本不出现,还是发了上面的邮件

苹果应用商店的邮件

修改设备支持

icon和splash

2019-01-03 11:28 负责人:无 分享
已邀请:
Trust

Trust - 少说废话

打包的时候,注意 iOS 平台的设备支持选项。

1***@qq.com

1***@qq.com (作者)

@DCloud_客服_Trust

非常感谢,弄好久啦。发布时没勾上支持ipad

要回复问题请先登录注册