阿哇
阿哇
  • 发布:2019-01-02 12:57
  • 更新:2021-09-02 14:19
  • 阅读:5813

在nvue中使用sass less

分类:nvue

烦啊,为了能在nvue中使用sass,我将hx安装包研究了个透,怎么做都不行,尽管找到了nvue的webpack,添加了sassloader一样不行。
后来没想到这么简单............

----右键项目根目录
----打开命令行
----npm init -y (初始化项目)
----npm install sass-loader -D (安装sass)

这样nvue中style标签就可以lang=scss啦
虽然还是不能嵌套书写,但是能继承已经很好了,配合上uni.scss(nvue需要手动@import),最大程度的可以跟vue文件公用样式

less stylus 应该无差异

3 关注 分享
1***@163.com zhangdaren [已删除]

要回复文章请先登录注册

1***@163.com

1***@163.com

你说的能继承是什么意思
2021-09-02 14:19
DCloud_UNI_GSQ

DCloud_UNI_GSQ

回复 [已删除] :
是的weex原本不支持, nvue是weex,weex只支持单个class选择器
2020-03-17 15:56
[已删除]

[已删除]

回复 DCloud_heavensoft :
不支持样式嵌套呀,是原本不支持嵌套,还是我写的有问题呀
2019-12-25 10:04
[已删除]

[已删除]

回复 DCloud_heavensoft :
支持嵌套吗,我说的是nvue,不是vue,在nuve中使用嵌套,真机运行报错,Selector `.index .header` is not supported. Weex only support single-classname selector,像这种错误,
2019-12-25 10:03