ocean_
ocean_
  • 发布:2021-09-14 14:24
  • 更新:2022-04-01 11:44
  • 阅读:10242

Error: Cannot find module '@dcloudio/uni-cli-i18n'

分类:uni-app

运行时错误

2021-09-14 14:24 负责人:无 分享
已邀请:

最佳回复

老糊涂

老糊涂

同时增加@dcloudio/uni-cli-i18n和@dcloudio/uni-i18n可以正常编译。
yarn add -D @dcloudio/uni-cli-i18n @dcloudio/uni-i18n

  • vikingleo

    老哥6啊!解决了,十分感谢!只提示找不到@dcloudio/uni-cli-i18n,还真不知道要安装@dcloudio/uni-i18n

    2021-10-06 14:50

  • Abstergo934

    困扰了好久,老哥牛的

    2021-10-20 16:56

  • 3***@qq.com

    厉害啊,感谢大佬

    2021-10-26 09:47

  • 5***@qq.com

    得加引号,我这不加引号,就不好使,后来百度查了,得加引号,果真好使了,然后我还得把我的yarn升级到1.22.4以上才可以

    yarn add -D "@dcloudio/uni-cli-i18n" "@dcloudio/uni-i18n"

    不过现在项目已成功起来了,非常感谢

    2021-11-25 16:03

  • DCloud_UNI_GSQ

    回复 5***@qq.com: 版本管理工具来了,看下面回复

    2021-11-29 17:38

  • 3***@qq.com

    感谢

    2022-01-05 18:40

  • 3***@qq.com

    感谢 啊 瞬间解决

    2022-06-07 11:36

DCloud_UNI_GSQ

DCloud_UNI_GSQ

3. 对于有变化的依赖进行增删,提示不存指定版本的依赖可以保留原始版本或者删除,运行时提示缺少的依赖自行安装。

  • 海蓝色

    同样的问题,即使指定版本依赖库安装下来还是最新版本,dev-mp:weixin 命令失效

    2021-09-29 17:28

  • 海蓝色

    建议你们创建一个新项目测试一下,沃一初 node_moudle文件夹 重新 执行 npm install 更新下来也是最新版本, 命令失效

    2021-09-29 17:30

  • alonely

    回复 海蓝色: 创建的一个新项目,还是出现了这个问题,是vue/cli版本的问题么

    2021-09-29 17:38

  • 海蓝色

    回复 alonely: 已经 npm update 最新版本

    2021-09-29 18:03

  • 海蓝色

    uni 的一些库引用const uniI18n = require('@dcloudio/uni-cli-i18n') 但实际只有@dcloudio/uni-i18n 这个插件 ,不知道官方有没有测试

    2021-09-29 18:11

  • Mr_hu

    我也遇到这个问题。。。

    2021-09-30 14:46

  • Mr_hu

    楼主解决没

    2021-09-30 14:46

  • DCloud_UNI_GSQ

    回复 alonely: 重试一下,或者手动添加 npm i @dcloudio/uni-cli-i18n

    2021-09-30 15:08

  • 9***@qq.com

    回复 DCloud_UNI_GSQ: 无效,添加之后运行如dev:h5之后就是直接“终端将被任务重用,按任意键关闭”,并不会正常编译。走Hbuilderx的话直接就卡在编译了。同时用vue cli构建的最新的项目,package.json内也只有一个uni-i18n的包,没有uni-cli-i18n的包,当然同样vue cli构建的新项目也是会直接报错的

    2021-09-30 16:01

  • DCloud_UNI_GSQ

    回复 9***@qq.com: package.json 内没有怎么能叫添加之后?

    2021-09-30 16:13

  • liaol

    回复 DCloud_UNI_GSQ: 最新版npm update就报这个错了,你们解决下啊,是不是删除了这个依赖啊

    2021-10-02 20:13

  • DCloud_UNI_GSQ

    回复 liaol: 这是新增的依赖,你手动安装一下即可 yarn add -D @dcloudio/uni-cli-i18n

    2021-10-08 12:05

vikingleo

vikingleo

一样遇到此问题,请问题主解决了没有?

m***@foxmail.com

m***@foxmail.com - hello word !

官方赶紧修复吧,2021-09-14 提的bug

我今天 2021-11-03 更新到最新版依旧出现了这个问题!!

  • DCloud_UNI_GSQ

    更新时不会自动安装新的依赖,需要手动安装一下。文档有说明的。

    2021-11-04 17:01

4***@qq.com

4***@qq.com

请问楼主这个怎么解决呀

  • vikingleo

    看1楼,可以解决

    2021-11-12 16:27

情哥哥

情哥哥

手动安装后,node_modules里的@dcloudio/vue-cli-plugin-hbuilderx报错,有同学遇到过吗

DCloud_UNI_GSQ

DCloud_UNI_GSQ

现在可以使用 @dcloudio/uvm 管理编译器的版本,示例:

npx @dcloudio/uvm
npx @dcloudio/uvm alpha
npx @dcloudio/uvm 3.2.12.20211029
npx @dcloudio/uvm 3.2.14.20211112-alpha
1***@qq.com

1***@qq.com

这句报错,我理解的意思是,需要安装app开发版的编辑器,我安装的不是app开发板,可以重新安装一下编辑器选择app开发试试!

要回复问题请先登录注册