t***@163.com
t***@163.com
  • 发布:2022-04-20 09:49
  • 更新:2022-04-20 11:11
  • 阅读:120

如何指定ios 云端打包版本

分类:HBuilderX

1.ios 云端打包 最新XCODE 配置版本为15

云端打包抛出错误如下 , 但是现在云端部分使用插件 兼容版本 还在14希望官网能做个指定版本打包

/Applications/Xcode.app/Contents/Developer/usr/bin/xcodebuild archive -sdk iphoneos15.2 -project [PackagePath]/HBuilder.xcodeproj -archivePath [PackagePath]/XArchive/HBuilder.xcarchive -scheme HBuilder CONFIGURATION=Release  

User defaults from command line:  
IDEArchivePathOverride = [PackagePath]/XArchive/HBuilder.xcarchive  
IDEPackageSupportUseBuiltinSCM = YES  

Build settings from command line:  
CONFIGURATION = Release  
SDKROOT = iphoneos15.2  

note: Using new build system  
note: Planning  
Analyze workspace
2022-04-20 09:49 负责人:DCloud_iOS_DJX 分享
已邀请:
DCloud_iOS_DJX

DCloud_iOS_DJX

把云端报错信息的链接发出来 我看看报什么错

  • 1***@qq.com

    https://ide.dcloud.net.cn/build/errorLog/fa0fa320-bfba-11ec-bb4f-a50d17eac38a

    2022-04-20 11:14

  • DCloud_iOS_DJX

    回复 1***@qq.com: _UTDevice 这个库没引入啊

    2022-04-20 11:39

  • 1***@qq.com

    回复 DCloud_iOS_DJX: 好的 目前问题阿里云登录认证原生模块,错误应该就是从这里报的。 需要找这个插件作者吗?还是有其它的方案

    2022-04-20 11:51

  • t***@163.com (作者)

    https://ide.dcloud.net.cn/build/errorLog/55d9ec70-beef-11ec-9e37-cfacf9be7282

    2022-04-20 14:16

  • DCloud_iOS_DJX

    回复 1***@qq.com: 先联系一下 这个插件作者

    2022-04-20 16:07

要回复问题请先登录注册