p***@163.com
p***@163.com
  • 发布:2024-05-13 12:32
  • 更新:2024-05-24 09:11
  • 阅读:119

通过旧版本发布的apk或者ipa,升级版本后发行的wgt是不是无法安装?

分类:HBuilderX

通过旧版本发布的apk或者ipa,升级版本后发行的wgt是不是无法启动?例如已经安装的应用是由Hbuilder X 4.06制作的,后续的wgt热更新包由4.16制作的,此时我们热更新后卡在启动页,无法启动

2024-05-13 12:32 负责人:DCloud_UNI_FXY 分享
已邀请:
祈愿稻荷神

祈愿稻荷神 - 刚毕业的社畜一枚

我的也是,目前只能开发工具恢复到Hbuilder X 4.06原来版本发布wgt资源包;

DCloud_UNI_FengXY

DCloud_UNI_FengXY

vue3项目?使用了pinia?

  • p***@163.com (作者)

    是的,vue3,用了pinia

    2024-05-16 19:22

  • DCloud_UNI_FengXY

    回复 p***@163.com: 参考这个帖子里的回复,在main.js补一段代码试试:

    https://ask.dcloud.net.cn/question/191289

    2024-05-16 19:36

  • p***@163.com (作者)

    回复 DCloud_UNI_FengXY: 好的

    2024-05-17 09:32

iOSDeveloper

iOSDeveloper - 专注于iOS相关领域。联系QQ:752562065

8年iOS开发,iOS相关的问题可以找我,解决不了不要钱,解决了给瓶水钱就行,我QQ752562065

祈愿稻荷神

祈愿稻荷神 - 刚毕业的社畜一枚

我这边排查到原因了,之前版本 import * as Decimal from '***/Decimal.js' 是正常的,
新版(只有APP)发现没法这样导入了,main.js直接报错不执行了,首页白屏.
改造下 Decimal 就可以了

要回复问题请先登录注册