kim猴
kim猴
  • 发布:2019-09-24 14:59
  • 更新:2019-09-25 12:40
  • 阅读:414

更新hbuilderX后之前的nav出现向上移位的问题,安装app第一次打开的时候会出现,重新进入app不会出现

分类:HBuilderX

更新hbuilderX后之前的nav出现向上移位的问题,安装app第一次打开的时候会出现,重新进入app不会出现

2019-09-24 14:59 负责人:无 分享
已邀请:
raymonster@qq.com

raymonster@qq.com

同样遇到了这个问题

kim猴

kim猴 (作者) - 90后程序媛

之前不会报这个,现在一直报这个问题

  • 1669607949@qq.com

    我也有这个

    2019-09-25 10:56

  • kim猴 (作者)

    回复 1669607949@qq.com: 这个可以复制到浏览器看看是报什么具体的错误,hbuilderx升级后好像不能看具体的报错信息。浏览器可以

    2019-09-29 16:43

DCloud_App_Array

DCloud_App_Array

Android还是iOS?请说明复现问题设备型号,提供复现问题的应用。

  • kim猴 (作者)

    苹果6s

    2019-09-24 15:53

  • kim猴 (作者)

    我把沉浸式去掉,第一次打开就没有这个问题了

    2019-09-24 15:53

  • kim猴 (作者)

    但是我需要沉浸式,之前不会有这个问题

    2019-09-24 15:53

  • kim猴 (作者)

    新增 windows 沉浸式标题栏。统一标题栏和界面主题的颜色,增加窗体内容区的高度(可在设置中切换回普通标题栏)和这个有关系吗?

    2019-09-24 15:55

  • kim猴 (作者)

    这个沉浸式标题栏有在什么地方说明吗?

    2019-09-24 18:34

kim猴

kim猴 (作者) - 90后程序媛

好像是沉浸式导致的,在配置文件里面设置了:
"statusbar" : {
"immersed" : "supportedDevice",
"style" : "light"
},

但是具体怎么解决还得看

豆豆xiao宽

豆豆xiao宽 - 静静的看着这个世界,最后终于疯了

我也出现了这个问题,script error.filename:lineno:0,这个错误好像是发请求时plusready没加载完毕。底部tabbar那个还没找到原因

  • kim猴 (作者)

    我去看看是不是这个原因导致的页面问题,感谢

    2019-09-24 16:44

  • kim猴 (作者)

    不是这个问题,伤感

    2019-09-24 18:06

DCloud_IOS_XTY

DCloud_IOS_XTY

请参考这个问题https://ask.dcloud.net.cn/question/79091

  • kim猴 (作者)

    照着设置了,可是没有用

    2019-09-25 09:29

  • 豆豆xiao宽

    同没有效果

    2019-09-25 11:07

  • kim猴 (作者)

    回复 豆豆xiao宽: 下面提供的方法有效,但是首页无效

    2019-09-25 13:14

kim猴

kim猴 (作者) - 90后程序媛

设置了之后没有用

邱水仙

邱水仙

是的,新版本更新后5+在ios上有这个问题存在,安卓还未发现

DCloud_IOS_XTY

DCloud_IOS_XTY

mui创建的window需要放到styles里

mui.openWindow({    
    url:new-page-url,    
    id:new-page-id,    
    styles:{    
      "contentAdjust":false    
    },

如何还是不行请提供可以运行复现问题的demo

  • kim猴 (作者)

    好。谢谢,我去试试,但是那个在配置文件设置的不可以的,我试了。就是上面那样写还是没有用

    2019-09-25 13:06

  • kim猴 (作者)

    我试了,这样写可以了,但是首页还是有问题

    2019-09-25 13:09

  • 豆豆xiao宽

    回复 kim猴: 我的也好用了,首页也都好使了,谢谢谢谢

    2019-09-25 13:58

  • kim猴 (作者)

    回复 豆豆xiao宽: 我首页不行得去喵喵为什么

    2019-09-25 14:10

  • 豆豆xiao宽

    回复 kim猴: plus.webview.create("url","id", {contentAdjust:false})这样的也要写上

    2019-09-25 14:34

  • kim猴 (作者)

    回复 豆豆xiao宽: 我现在是首页不行,就是在配置文件设置launchwebview不行,别的页面设置style就可以了

    2019-09-25 14:52

  • kim猴 (作者)

    可以了。感谢

    2019-09-25 15:45

  • kim猴 (作者)

    还有一个问题是,进入页面会先进入空白页,然后再跳转,之前不会的

    2019-09-25 15:46

要回复问题请先登录注册