迪丽热bug
迪丽热bug
  • 发布:2019-10-31 17:08
  • 更新:2020-04-30 10:47
  • 阅读:1007

【未知原因】uniapp升级2.3.7最新版本后底部tabbar不显示

分类:uni-app

最近迭代功能时,真机测试时手机自动替换了最新的hbx 。--(检测到hbx基座有最新,正在删除旧版本...)

然后运行项目时,发现原有项目的底部tabbar不显示了。接着更新了hbx编辑器(2.3.7)。经过2天的排除,发现是自定义编译模式引起的。当我勾选自定义编译模式时底部tabbar不显示 不勾选时显示tabbar但是所有页面都是空白。

于是 我找了社区的一些资料 说是cli版本的话要手动npm update 接着更新了 然后重新启动时报错:
module.js:549
16:39:29.411 throw err;
16:39:29.414 ^
16:39:29.418 Error: Cannot find module 'C:\Users\Administrator.T7QIAN93K5B0QYT\Desktop\xxx-project\node_modules\@vue\cli-service\bin\vue-cli-service.js'

我安装对应的依赖包都会报错:
npm ERR! path C:\Users\Administrator.T7QIAN93K5B0QYT\Desktop\xxx-project\node_modules.node-sass.DELETE\vendor\win32-x64-57\binding.node
npm ERR! code EPERM
npm ERR! errno -4048
npm ERR! syscall unlink
npm ERR! Error: EPERM: operation not permitted, unlink 'C:\Users\Administrator.T7QIAN93K5B0QYT\Desktop\recovery-app2\node_modules.node-sass.DELETE\vendor\win32-x64-57\binding.node'
npm ERR! { Error: EPERM: operation not permitted, unlink 'C:\Users\Administrator.T7QIAN93K5B0QYT\Desktop\recovery-app2\node_modules.node-sass.DELETE\vendor\win32-x64-57\binding.node'
npm ERR! cause:
npm ERR! { Error: EPERM: operation not permitted, unlink 'C:\Users\Administrator.T7QIAN93K5B0QYT\Desktop\recovery-app2\node_modules.node-sass.DELETE\vendor\win32-x64-57\binding.node'
npm ERR! errno: -4048,
npm ERR! code: 'EPERM',
npm ERR! syscall: 'unlink',
....

vue-cli-service和node-sass 所有需要依赖的包重新安装了都没用...
有小伙伴遇到同样的问题的吗???

2019-10-31 17:08 负责人:无 分享
已邀请:
yymcct@qq.com

yymcct@qq.com

2.3.3的可以 2.3.7的就空白

zyk2019

zyk2019

讲真的,官方每次升级就像凑着玩似的。。。。

yymcct@qq.com

yymcct@qq.com

有, 同问,tabbar 所占高度还在, 显示空白

  • 迪丽热bug (作者)

    2.3.3之前的也行 但是真机测试时强制更新了 现在也无法退回版本 原来不是我一个人遇到这个问题 现在项目要迭代 我要裂开

    2019-11-01 08:38

1121112856@qq.com
迪丽热bug

迪丽热bug (作者)

迪丽热bug

迪丽热bug (作者)

升级cli后 报错 安装对应的依赖后还是报一堆错

迪丽热bug

迪丽热bug (作者)

退回cli版本以及hbx版本(2.3.3)后 hbx编辑器不能使用

迪丽热bug

迪丽热bug (作者)

npm update后运行报错如下:

DCloud_UNI_FXY

DCloud_UNI_FXY

npm run info,贴出来各个依赖版本号

  • 迪丽热bug (作者)

    刚刚解决了 不能使用update全部更新

    2019-11-01 14:09

  • 1542796041@qq.com

    ➜ uniApp-project git:(baidu) ✗ npm run info


    > uni-tingting@0.1.0 info /Users/macpro_wst/workspace/Work/uniApp-project

    > node node_modules/@dcloudio/vue-cli-plugin-uni/commands/info.js


    uni-app v2.2.4

    uni-app cli v2.0.0-24220191115006


    Environment Info:


    System:

    OS: macOS 10.15.1

    CPU: (8) x64 Intel(R) Xeon(R) CPU E5-1620 v2 @ 3.70GHz

    Binaries:

    Node: 12.10.0 - /usr/local/bin/node

    Yarn: 1.17.3 - /usr/local/bin/yarn

    npm: 6.12.1 - /usr/local/bin/npm

    Browsers:

    Chrome: 78.0.3904.108

    Firefox: 70.0.1

    Safari: 13.0.3

    npmPackages:

    @dcloudio/uni-app-plus: => 0.0.253

    @dcloudio/uni-app-plus-nvue: 0.0.1

    @dcloudio/uni-app-plus-nvue-v8: 0.0.1

    @dcloudio/uni-cli-shared:
    => 0.2.994

    @dcloudio/uni-h5: => 0.9.0

    @dcloudio/uni-mp-alipay:
    => 0.0.827

    @dcloudio/uni-mp-baidu: => 0.0.857

    @dcloudio/uni-mp-qq:
    => 0.0.112

    @dcloudio/uni-mp-toutiao: => 0.0.352

    @dcloudio/uni-mp-weixin:
    => 0.0.973

    @dcloudio/uni-stat: 2.0.0-24220191115006

    @dcloudio/uni-template-compiler: ^0.9.183 => 0.9.183

    @dcloudio/vue-cli-plugin-hbuilderx: ^2.0.0-24220191115006 => 2.0.0-24220191115006

    @dcloudio/vue-cli-plugin-uni: ^2.0.0-24220191115006 => 2.0.0-24220191115006

    @dcloudio/webpack-uni-mp-loader: => 0.3.644

    @dcloudio/webpack-uni-nvue-loader: 0.0.1

    @dcloudio/webpack-uni-pages-loader:
    => 0.2.875

    @vue/babel-helper-vue-jsx-merge-props: 1.0.0

    @vue/babel-plugin-transform-vue-jsx: 1.0.0

    @vue/babel-preset-app: 3.9.2

    @vue/babel-preset-jsx: 1.1.0

    @vue/babel-sugar-functional-vue: 1.0.0

    @vue/babel-sugar-inject-h: 1.0.0

    @vue/babel-sugar-v-model: 1.0.0

    @vue/babel-sugar-v-on: 1.1.0

    @vue/cli-overlay: 3.12.1

    @vue/cli-plugin-babel: 3.5.1 => 3.5.1

    @vue/cli-service: ^3.12.1 => 3.12.1

    @vue/cli-shared-utils: 3.9.0

    @vue/component-compiler-utils: 3.0.0

    @vue/preload-webpack-plugin: 1.1.1

    @vue/web-component-wrapper: 1.2.0

    babel-helper-vue-jsx-merge-props: 2.0.3

    fundebug-vue: ^0.0.1 => 0.0.1

    mpvue-citypicker: ^1.0.6 => 1.0.6

    mpvue-page-factory: 1.0.1

    mpvue-template-compiler: 1.0.13

    uni-h5-vue: 2.6.10

    uni-mp-vue: 2.6.10

    vue: ^2.6.10 => 2.6.10

    vue-content-loader: ^0.2.2 => 0.2.2

    vue-hot-reload-api: 2.3.4

    vue-lazyload: ^1.3.3 => 1.3.3

    vue-loader: ^15.7.2 => 15.7.2

    vue-router: 3.0.1

    vue-style-loader: 4.1.2

    vue-template-compiler: ^2.6.10 => 2.6.10

    vue-template-es2015-compiler: 1.9.1

    vuex: ^3.1.2 => 3.1.2

    npmGlobalPackages:

    @vue/cli: 4.0.4


    ----------------------同样的问题-----------

    2019-11-27 18:13

  • 1542796041@qq.com

    请求的页面无法打开:file:///storage/emulated/0/Android/data/io.dcloud.HBuilder/apps/HBuilder/www/__uniapptabbar.html at file:///android_asset/data/dcloud_error.html:41

    2019-11-27 18:25

18633753573@163.com

18633753573@163.com

我又裂开了。。。。你们是回退版本解决的么? 因为我现在都到了2.4版本,问题跟楼主的一样,但是我的不报错。只是底部tabBar不显示

784075782@qq.com

784075782@qq.com

请问最后怎么解决的呢?急~~

  • 迪丽热bug (作者)

    你好 刚看到 我已经解决了 ~ 但是我忘记怎么弄的了哈哈哈 好像是删除依赖再更新

    2020-05-13 17:19

  • 淡然如是

    回复 迪丽热bug: 裤子都脱了,你给我看这个……

    2020-05-18 15:40

要回复问题请先登录注册