一枚小前端
一枚小前端
  • 发布:2020-05-20 15:06
  • 更新:2020-05-21 18:46
  • 阅读:194

版本2.7.5之后,强制使用V3模式,如何使用iconfont

分类:uni-app

编辑器更新到 2.7.5 之后,页面的渲染模式强制变成 V3 编译,而且不能修改。但是原来在 main.js 中引入的 iconfont.css 无法正常使用。但是修改成在 App.vue 中引入,依旧无法解决问题,同时也将 iconfont.css 的路径改为 ~@/.... 了。

甚至根据论坛中提供的方法,将 iconfont.tff 转换为 base64 替换到 iconfont.css 中,依旧无法解决问题。

有朋友们遇到这个问题的吗?希望给予一些技术支持。

2020-05-20 15:06 负责人:无 分享
已邀请:
爱吃鱼的靖哥哥

爱吃鱼的靖哥哥 - 行走在全栈路上的码农

看到你这个帖子我不禁看了下我的app,还能用啊,没啥问题啊

一枚小前端

一枚小前端 (作者) - 前端工程师

你的编辑器是多少的,我的是2.7.5的,你的渲染模式是普通渲染还是V3

爱吃鱼的靖哥哥

爱吃鱼的靖哥哥 - 行走在全栈路上的码农

我的是mac版的2.7.4.20200515-alpha,都是强制V3模式

  • 一枚小前端 (作者)

    问题解决了,我把字体从common文件夹放到了static,重启了一下电脑,可以了,不知道是不是电脑问题。谢谢

    2020-05-20 15:21

  • 爱吃鱼的靖哥哥

    回复 一枚小前端: 字体文件好像不能放static外面吧

    2020-05-20 15:23

  • 一枚小前端 (作者)

    回复 爱吃鱼的靖哥哥: 嗯嗯,现在放在static了,以前旧版本可以用,就一直放在我自己创建的common文件夹下

    2020-05-20 15:51

爱吃鱼的靖哥哥

爱吃鱼的靖哥哥 - 行走在全栈路上的码农

正式版居然发布新版本了,666,我就是嫌正式版更新太慢,后来换成alpha版了

  • 一枚小前端 (作者)

    可以更新新版本了,2.7.5,只支持v3,相信运行速度会更快点了吧。

    2020-05-20 15:51

包航行

包航行

我的也不行 尝试了你的办法 没效果啊

  • 爱吃鱼的靖哥哥

    你怎么用的啊,上代码

    2020-05-22 08:49

  • 一枚小前端 (作者)

    iconfont.css中的几个路径修改为,~@/你的路径,我的为~@/static/font...... 然后在App.vue中引入iconfont.css

    2020-05-22 09:16

要回复问题请先登录注册