8***@qq.com
8***@qq.com
  • 发布:2022-09-16 09:45
  • 更新:2022-10-27 10:39
  • 阅读:1793

当前自定义基座包不支持新版本真机运行,请重新生成自定义基座包再调试运行

分类:HBuilderX

更新hbuilder后,运行真机调试报错: 当前自定义基座包不支持新版本真机运行,请重新生成自定义基座包再调试运行。

重新打包自定义基座也不行。

hbuilder版本: 3.6.2.20220914

2022-09-16 09:45 负责人:无 分享
已邀请:

最佳回复

DCloud_HB_WDL

DCloud_HB_WDL

  1. 如果手机上存在旧的应用,删除后试试。
  2. HBuilderX菜单【工具】【插件安装】,看下uniapp编译器、App真机运行插件版本号。通常,这些插件的版本号,跟HBuilderX版本号一致,如果不一致,请卸载插件,重新安装
  3. 如果是uniapp cli项目,请升级下cli
  4. 如果是Android Studio构建的自定义基座,请暂时使用HBuilderX构建自定义基座。原因:自行用Android Studio构建的自定义基座,缺失某个版本号信息,所以出现了此提示。
  • 8***@qq.com (作者)

    试过删除,也是不行

    2022-09-16 10:47

  • Yitind

    也出现更新之后,新的自定义基座包不能使用

    2022-09-16 12:46

  • 1***@163.com

    删除也不行

    2022-09-17 10:01

  • l***@163.com

    不行,不行,试了无数次,什么办法都用过了

    2022-09-17 15:11

  • DCloud_HB_WDL

    回复 l***@163.com: 发下QQ,我们联系你,解决下问题

    2022-09-19 13:44

  • aak12345

    不行。

    2022-09-19 22:18

  • DCloud_HB_WDL

    回复 aak12345: 参考: https://ask.dcloud.net.cn/article/40050

    2022-09-21 15:50

  • 8***@qq.com (作者)

    回复 8***@qq.com: 走第2, 第3步,加重新制作自定义基座可以调试了。

    2022-09-21 17:52

minddewo

minddewo

我也出现相同的问题。安卓原生升级了所以aar,生成的基座在HBuilder里提示 “当前自定义基座包不支持新版本真机运行,请重新生成自定义基座包再调试运行”,重启、清理。卸载了都不行。不升级之前都是好的。麻烦速度解决下呀。

  • DCloud_HB_WDL

    参考: https://ask.dcloud.net.cn/article/40050

    2022-09-21 15:50

Yitind

Yitind

在真机上运行不了

  • DCloud_HB_WDL

    参考: https://ask.dcloud.net.cn/article/40050

    2022-09-21 15:50

l***@sohu.com

l***@sohu.com - 中年大叔,啥都会一点,技术偏执。目前从事Android系统开发、linux以及驱动开发。

HbuilderX 3.6.2到3.6.3都有这个问题

  • DCloud_HB_WDL

    参考: https://ask.dcloud.net.cn/article/40050

    2022-09-21 15:50

x***@xgimi.com

x***@xgimi.com

我也是这样

  • DCloud_HB_WDL

    参考: https://ask.dcloud.net.cn/article/40050

    2022-09-21 15:50

4***@qq.com

4***@qq.com - undefined

俺也一样

  • DCloud_HB_WDL

    参考: https://ask.dcloud.net.cn/article/40050

    2022-09-21 15:50

z***@duoqin.com
  • DCloud_HB_WDL

    参考: https://ask.dcloud.net.cn/article/40050

    2022-09-21 15:50

1***@163.com

1***@163.com

一样的问题,我先回退了

  • DCloud_HB_WDL

    参考: https://ask.dcloud.net.cn/article/40050

    2022-09-21 15:50

l***@163.com

l***@163.com

我也是。。。安卓不行

  • DCloud_HB_WDL

    参考: https://ask.dcloud.net.cn/article/40050

    2022-09-21 15:50

w***@sina.com

w***@sina.com

我都直接回退版本了

  • DCloud_HB_WDL

    参考: https://ask.dcloud.net.cn/article/40050

    2022-09-21 15:50

len168com

len168com

一样的问题

  • DCloud_HB_WDL

    参考: https://ask.dcloud.net.cn/article/40050

    2022-09-21 15:50

DCloud_App_Array

DCloud_App_Array

首先尝试重新制作自定义基座,如果还存在此问题,请按以下方法操作:

  1. HBuilderX中创建的项目
    通过菜单打开“工具” -> “插件安装”,在“已安装插件”中tab项中卸载“App真机运行”插件,再切换到“安装新插件”tab项中重新选择“App真机运行”插件安装
    安装插件后重新制作自定义调试基座
  2. 通过cli命令创建的项目
    更新cli命令到最新版本后,在重新制作自定义调试基座
  • l***@163.com

    根本就不行

    2022-09-18 15:14

  • l***@sohu.com

    麻烦解决下 从3.6.2到3.6.3了一直都是这样

    2022-09-18 18:03

  • DCloud_HB_WDL

    回复 l***@sohu.com: 需要详情才能定位问题,发下QQ,我们加你排查一下问题

    2022-09-19 13:44

  • twolf

    回退上一个版本,不行。按你说的,尝试了一下,还是不行。我要发布新版本,莫名出现各种问题,我都不敢更新。

    2022-09-21 11:14

  • twolf

    能不能速度优先处理一下。测试扣鸡腿!测试扣鸡腿!测试扣鸡腿!测试扣鸡腿!测试扣鸡腿!

    2022-09-21 11:15

  • DCloud_HB_WDL

    回复 twolf: 参考: https://ask.dcloud.net.cn/article/40050

    2022-09-21 15:50

水陌言生

水陌言生

问题: 提示 ”当前自定义基座包不支持新版本真机运行,请重新生成自定义基座包再调试运行“

环境:

  1. 版本: 3.6.3.20220917
    2.下载最新的项目SDK从百度云,不过最新为3.6.2,
  2. 本地android studio 运行没有问题, 但是制作自定义基座, 提示 ”当前自定义基座包不支持新版本真机运行,请重新生成自定义基座包再调试运行“
  • DCloud_HB_WDL

    是通过Android Studio生成的自定义基座? 在HBuilderX,提交云打包,使用这个生成的自定义基座正常吗?

    2022-09-19 15:00

  • 木叶96

    回复 DCloud_HB_WDL: Android Studio生成的自定义基座无法真机调试,云打包的自定义基座可以调试,这是什么原因呢

    2022-09-19 17:02

  • l***@163.com

    回复 DCloud_HB_WDL: 云打包的自定义基座也不能用,,,看我下边的截图,怎么弄,着急调试啊,啥时候修复啊

    2022-09-19 17:25

  • DCloud_HB_WDL

    回复 木叶96: HBuilderX运行到自定义基座,判断了一个版本号,Android Studio生成的自定义基座,没有这个版本号信息。所以提示了这个信息。  内部已正在处理此问题。

    2022-09-19 22:55

l***@163.com

l***@163.com

给解决一下啊

  • DCloud_HB_WDL

    从你截图来看,是uniapp cli项目。升级下cli

    2022-09-19 22:56

  • 好人事

    回复 DCloud_HB_WDL: 最新安卓3.6.3sdk打包依旧 无法解决呀

    2022-09-19 23:00

  • DCloud_HB_WDL

    回复 z***@126.com: 看最上面的第一个回复。

    2022-09-19 23:05

  • DCloud_HB_WDL

    参考: https://ask.dcloud.net.cn/article/40050

    2022-09-21 15:50

aak12345

aak12345

请问解决没?

  • DCloud_HB_WDL

    参考: https://ask.dcloud.net.cn/article/40050

    2022-09-21 15:49

3***@qq.com

3***@qq.com

回退版本吧,没辙!

  • DCloud_HB_WDL

    参考: https://ask.dcloud.net.cn/article/40050

    2022-09-21 15:49

len168com

len168com

3.6.3 一样问题

  • DCloud_HB_WDL

    看下最上面的回复,根据这个排查一下。

    2022-09-20 17:27

  • DCloud_HB_WDL

    参考: https://ask.dcloud.net.cn/article/40050

    2022-09-21 15:49

5***@qq.com

5***@qq.com

如果是Android Studio构建的自定义基座,请暂时使用HBuilderX构建自定义基座。原因:自行用Android Studio构建的自定义基座,缺失某个版本号信息,所以出现了此提示。内部正在处理。

请问下这个什么时候能够解决?

1***@qq.com

1***@qq.com

3.6.2真机调试 用官方的debug还能调试,但是升级到3.6.3 无法用了自定义基座了然后官方的debug调试就显示不出来了,只显示一半,调试内容不显示。然后回退到3.6.2可以显示debug内容了。但是提示:当前使用的自定义基座的SDK版本为:1.9.9.80936,标准运行基座的SDK版本为:1.9.9.80918,SDK版本不一致,可能有兼容问题,请及时制作新版自定义基座。不知道是否影响。求官方回复

l***@sohu.com

l***@sohu.com - 中年大叔,啥都会一点,技术偏执。目前从事Android系统开发、linux以及驱动开发。

自定义基座调试遇到问题的朋友们, 可以看看:https://ask.dcloud.net.cn/question/153809

8***@qq.com

8***@qq.com (作者)

按照最佳回复操作,我升级了hbuilder x版本为最新3.6.3.20220917, 然后重装了真机运行插件和编译插件,我的项目是cli创建的,也升级了cli插件,再使用hbuilder x制作自定义基座后可以调试了。遇到同样的问题的朋友可以参考下。

  • 1***@qq.com

    我hbuilder x为3.6.4重装了运行和编译插件,cli是4.5.19的,重新自定义基座之后还是不行,该怎么解决啊?

    2022-09-26 11:20

良非

良非

app版本号升级(例100=>101)一下再打个包试试呢?

z***@163.com

z***@163.com

当前自定义基座包不支持新版本真机运行,请重新生成自定义基座包再调试运行。1.如果是uni-app CLI项目,请升级CLI编译器 请参考:https://uniapp.dcloud.net.cn/quickstart-cli.html 后重新制作自定义基座;
同样问题,请问怎么解决呢

  • DCloud_HB_WDL

    这个一般来说,构建的自定义基座存在问题。请在HBuilderX中,使用云打包,提交制作自定义基座试试。

    2022-10-24 16:02

该问题目前已经被锁定, 无法添加新回复