1***@qq.com
1***@qq.com
  • 发布:2024-01-26 10:50
  • 更新:2024-03-29 12:47
  • 阅读:119

uniapp 安卓打包失败,本地运行正常

分类:uni-app

https://ide.dcloud.net.cn/build/errorLog/7c31bf40-bbf4-11ee-89eb-bb6abb179cfe

前天打包是正常的

这是一个Android项目中的依赖库版本冲突问题。

问题描述如下:

你的项目中的AndroidManifest.xml文件有一些警告,这些警告主要是关于命名空间的映射,这些警告一般不会导致运行时错误,但可能会影响你使用某些新特性或API。
主要的错误是关于minSdkVersion的值。你的项目的minSdkVersion是19,但其中一个依赖库(FUN-AmapLocation-release.aar)的minSdkVersion是21。这意味着你的应用要求最低Android版本为4.4(API级别19),但该库需要最低Android版本为5.0(API级别21)

2024-01-26 10:50 负责人:无 分享
已邀请:
II优选

II优选 - 定制插件开发-联系QQ:770104707

hb 设置成21 就好了

1***@qq.com

1***@qq.com (作者)

在哪设置呢

  • II优选

    其他设置 android 设置

    2024-01-26 11:05

1***@qq.com

1***@qq.com (作者)

ok,谢谢,已解决

  • II优选

    好的,如有原生插件开发,可以联系我哦

    2024-01-26 11:12

iOSDeveloper

iOSDeveloper - 专注于iOS相关领域。联系QQ:752562065

解决了么

要回复问题请先登录注册