光光阿斯蒂芬
光光阿斯蒂芬
  • 发布:2017-07-05 10:53
  • 更新:2019-09-12 20:25
  • 阅读:3194

在线打包能设置 targetSdkVersion 吗?

分类:HTML5+

RT:在线打包能设置 targetSdkVersion 吗?

2017-07-05 10:53 负责人:无 分享
已邀请:

最佳回复

DCloud_App_Array

DCloud_App_Array

此功能HBuilder最新版及 HBuilder X版本已支持。
5+app在manifest.json的plus->distribute->google->targetSdkVersion添加配置:

    "plus": {  
        "distribute": {  
            "google":{  
                              "targetSdkVersion":26  
            }  
        }  
    }

注意:目前5+仅在targetSdkVersion=21(默认值)环境下完整测试过,无法保证设置其它值不出问题。

如果是uni-app应该在manifest.json文件的"app-plus"->"distribute"->"android"节点下添加"targetSdkVersion",值必须是数字,不需要使用双引号。

  • jtshushu

    MUI 呢 框架呢

    2018-08-03 15:11

  • jtshushu

    我这没看到这 是不是自已加 "targetSdkVersion":"26",

    2018-08-03 15:14

  • DCloud_App_Array

    是的,需要手动添加这个字段

    2018-08-03 15:19

  • jtshushu

    回复 DCloud_App_Array:我加了打包还是21阿 急急

    2018-08-03 16:16

  • jtshushu

    回复 DCloud_App_Array:我的MUI 的框架 加了 "google": {

    "targetSdkVersion":"26", //自己加入

    "packagename": "",/Android应用包名,如io.dcloud.HelloH5/


    发布还是21的 云打包不行26不能变成26有解决方法吗

    2018-08-03 16:18

  • jtshushu

    怎么在你们这个文章中说

    云服务还不支持

    targetSdkVersion

    仅支持设置minSdkVersion


    http://ask.dcloud.net.cn/question/54169

    2018-08-03 16:28

  • DCloud_App_Array

    请提供下应用的appid(manifest.json文件中id字段值)

    2018-08-03 16:38

  • jtshushu

    1.1.6版本

    2018-08-03 16:45

  • jtshushu

    io.dcloud.H520137D4

    这是包名


    [HBuilder] 15:46:55.746 项目 TruckBook [H520137D4]打包成功:

    下载地址:

    2018-08-03 16:48

  • jtshushu

    大神能帮我解决一下吗 我都一天时间弄这个了

    因为我发布的谷歌上

    我要求一定要26的

    2018-08-03 16:50

  • jtshushu

    回复 DCloud_App_Array: "id": "H520137D4",/应用的标识,创建应用时自动生成,勿手动修改/

    我加了打包还是21阿 能帮我看一下吗

    2018-08-03 16:57

  • jtshushu

    回复 DCloud_App_Array:

    您好!

    io.dcloud.H520137D4

    这是包名


    [HBuilder] 15:46:55.746 项目 TruckBook [H520137D4]打包成功:

    下载地址:

    2018-08-03 17:04

  • jtshushu

    谢谢 "targetSdkVersion":26,不加引号吧

    2018-08-06 09:30

head_foward@yeah.net
1280424531@qq.com
cydida

cydida

同问

webyezi@msn.com

webyezi@msn.com

同问设置也用 HBuilder X 但是还是21

  • DCloud_App_Array

    请确认下创建的是uni-app还是5+app,请提供下appid(manifest.json中的id字段值)。

    如果是uni-app应该在manifest.json文件的"app-plus"->"distribute"->"android"节点下添加"targetSdkVersion"。

    2018-08-02 20:36

  • jtshushu

    我是MUI app 没有这个东西 我是加入了 打包也是 21

    2018-08-03 16:54

jtshushu

jtshushu - php-Thinkphp python MUI uniApp Vuejs Bootstrap

同问

ouweican@126.com

ouweican@126.com

我设置了targetSdkVersion=23,导致直播推流失败,求解决。

  • jtshushu

    HBuilder X

    2018-09-18 18:48

  • jtshushu

    在这个文件manifest.json 在 "google" : {


    "targetSdkVersion" : 26, //自己加入

    2018-09-18 18:50

  • jtshushu

    回复 jtshushu:打包

    2018-09-18 18:50

Kenny018

Kenny018

设置后,地图定位那些功能不行了。还是要离线打包

1343225411@qq.com

1343225411@qq.com

targetsdkversion设置成28后,打不开了,打开直接黑屏。。

  • jtshushu

    看你打包什么平台的 要用最新的软件打包

    2019-09-17 18:16

1343225411@qq.com

1343225411@qq.com

而且也无法退回之前的版本,会提示无法降级

要回复问题请先登录注册