网红
网红
  • 发布:2019-08-13 15:40
  • 更新:2020-10-31 16:51
  • 阅读:1918

uni-app的button自动转换成uni-button,导致第三方库不兼容问题

分类:uni-app

问题描述

我在使用uni-app开发,在H5端使用了富文本编辑器quill,编辑器所有使用button的按钮图标不显示。

排查解决

经过多次尝试发现是由于第三方插件库中绘制的button的问题,如果将quill.js中所有绘制button的改成uni-button则会正常,求问更好的解决方案?我该如何使用类似的第三方的包,尴尬。

uniapp很棒,加油!

2019-08-13 15:40 负责人:无 分享
已邀请:
DCloud_UNI_GSQ

DCloud_UNI_GSQ

因为你使用的button和uni-app的button同名,所以button都会编译为uni-app的button组件(即h5端为uni-button,类似于在微信为wx-button)
目前你只能修改调整此类第三方库

  • 网红 (作者)

    好的,感谢!

    2019-08-19 17:06

向

你好 请问下具体的按钮修改是怎样的么

  • 网红 (作者)

    您好,才看到,这里有具体修改,readme.md里有说明 https://github.com/ShyZhen/fmock-uniapp

    2021-02-03 12:23

要回复问题请先登录注册