1242955981@qq.com
1242955981@qq.com
  • 发布:2019-10-10 11:30
  • 更新:2019-10-10 12:39
  • 阅读:183

原生插件更新之前购买使用的,在更新后如何使用最新版的

分类:uni-app

原生插件更新之前购买使用的,在更新后如何使用最新版的

2019-10-10 11:30 分享
已邀请:
DCloud_Android_ST

DCloud_Android_ST

重新打包

DCloud_App_Array

DCloud_App_Array

通过打包日志看,打包机上使用的插件(JY-JPush)版本为1.3.0,与最后一次提交通过审核的版本一致。
是如何确定重新打包后没有使用新版本的插件的?
如果使用自定义基座测试,请先手动删除手机上已经安装的旧版本,确保安装的是新打包生成的。

  • 1242955981@qq.com (作者)

    已经删除手机上安装的。确定没有新版的是使用了JY-JPush的实例,并无打印效果

    validJYJPushTags(){

    const jyJPush = uni.requireNativePlugin('JY-JPush');

    jyJPush.validJYJPushTags({

    userTag: '需要验证的tag'

    }, result=> {

    uni.showToast({

    icon:'none',

    title: JSON.stringify(result)

    })

    });

    },

    getJYJPushTags() {

    const jyJPush = uni.requireNativePlugin('JY-JPush');

    jyJPush.getJYJPushTags(

    result=> {

    uni.showToast({

    icon:'none',

    title: JSON.stringify(result)

    })

    });

    },

    cleanJYJPushTags() {

    const jyJPush = uni.requireNativePlugin('JY-JPush');

    jyJPush.cleanJYJPushTags(

    result=> {

    uni.showToast({

    icon:'none',

    title: JSON.stringify(result)

    })

    });

    },

    2019-10-10 12:48

  • 1242955981@qq.com (作者)

    使用的是getJYJPushTags这个api

    2019-10-10 12:48

  • 1242955981@qq.com (作者)

    怎么样,有结论了吗

    2019-10-10 14:47

  • DCloud_App_Array

    回复 1242955981@qq.com: 已经比较确认打包机上使用的插件与最后提交审核通过的版本一致,请确认提交的插件是否正确。请使用本地插件提交云端打包确认插件是否正确,参考:http://ask.dcloud.net.cn/article/35844

    2019-10-10 15:32

要回复问题请先登录注册