DCloud_UNI_GSQ
DCloud_UNI_GSQ
  • 发布:2021-02-03 21:01
  • 更新:2022-01-29 00:39
  • 阅读:8011

nvue 样式编译模式介绍

分类:uni-app

HBuilderX 3.1.0+ 开始支持新的样式编译模式

  • weex 编译模式:老模式,样式支持与普通 weex 相同
  • uni-app 编译模式:新模式,在 weex 原有样式基础上支持组合选择器(相邻兄弟选择器、普通兄弟选择器、子选择器、后代选择器),目前已知问题:list 组件内嵌套的组件动态更新 class 无效,将在 3.1.2 修复

3.1.0 alpha 版为 uni-app 模式,3.1.1 开始缺省值为 weex 模式,切换编译模式需要重新运行

配置方式

// manifest.json  
{        
    // ...        
     /* App平台特有配置 */        
    "app-plus":  {  
        "nvueStyleCompiler": "uni-app"  
    }  
}
2 关注 分享
sonicsunsky QLing

要回复文章请先登录注册

棒榜

棒榜

回复 1***@qq.com :
一样的问题,请问解决了么
2022-01-29 00:39
LRL啊

LRL啊

回复 _孙大圣_ :
非常感谢大哥,这个问题困惑我很久了,始终没找到答案。谢谢大哥
2022-01-20 10:11
_孙大圣_

_孙大圣_

回复 LRL啊 :
你说的没错,Cell上不要绑定class,绑定class,会一个个慢慢加载- -,
2022-01-19 20:14
LRL啊

LRL啊

回复 _孙大圣_ :
啊?大哥你的意思是说我出现的问题是因为在cell上绑定了class导致的?cell组件只能作为一个载体组件吗?像block组件一样?这个问题我之前一直没找到问题出在哪里。
2022-01-19 17:12
_孙大圣_

_孙大圣_

回复 LRL啊 :
class不能绑定在cell上
2021-12-31 18:48
DCloud_UNI_GSQ

DCloud_UNI_GSQ (作者)

回复 LonerWalker :
仅支持 class 选择器
2021-10-19 14:37
LonerWalker

LonerWalker

子选择器在android上还是不生效,如:```.header>text{xxxxxxxxxxxx}```
2021-10-15 16:23
LonerWalker

LonerWalker

子选择器在android上还是不生效,如:.header>text{xxxxxxxxxxxx}
2021-10-15 16:23
LRL啊

LRL啊

一旦设置这个模式后,我在长列表下拉刷新,清空list数组时在list - call组件是一个一个依次慢慢销毁的,一个下拉刷新让列表闪了很多下,不知道是为什么。
2021-09-27 11:15
1***@qq.com

1***@qq.com

版本:3.1.13.20210514,app 编译模式: uni-app
nvue 页面使用 uni-popup 组件样式报错:
17:46:10.790 ERROR: Selector `.uni-popup.top` is not supported. Weex only support classname selector at uni_modules/uni-popup/components/uni-popup/uni-popup.vue:30
17:46:10.795 ERROR: Selector `.uni-popup.left` is not supported. Weex only support classname selector at uni_modules/uni-popup/components/uni-popup/uni-popup.vue:30
17:46:10.797 ERROR: Selector `.uni-popup.right` is not supported. Weex only support classname selector at uni_modules/uni-popup/components/uni-popup/uni-popup.vue:30
17:46:10.803 ERROR: Selector `.uni-popup .uni-popup__wrapper` is not supported. Weex only support classname selector at uni_modules/uni-popup/components/uni-popup/uni-popup.vue:33
17:46:10.803 ERROR: Selector `.uni-popup .uni-popup__wrapper.left` is not supported. Weex only support classname selector at uni_modules/uni-popup/components/uni-popup/uni-popup.vue:37
17:46:10.809 ERROR: Selector `.uni-popup .uni-popup__wrapper.right` is not supported. Weex only support classname selector at uni_modules/uni-popup/components/uni-popup/uni-popup.vue:37
2021-06-08 17:58