越王够贱
越王够贱
  • 发布:2022-01-18 19:37
  • 更新:2022-07-13 17:36
  • 阅读:734

npm update 后打包后编译不过Invalid options object. Sass Loader has been initialized

分类:uni-app

错误信息
19:36:03.831 Module build failed (from ./node_modules/@dcloudio/vue-cli-plugin-uni/packages/sass-loader/dist/cjs.js):
19:36:03.833 ValidationError: Invalid options object. Sass Loader has been initialized using an options object that does not match the API schema.
19:36:03.839 - options has an unknown property 'data'. These properties are valid:
19:36:03.839 object { implementation?, sassOptions?, prependData?, sourceMap?, webpackImporter? }
19:36:03.845 at validate (D:\HBuliderW\LuzhuaAPP\node_modules\@dcloudio\vue-cli-plugin-uni\packages\sass-loader\node_modules\schema-utils\dist\validate.js:96:11)
19:36:03.853 at Object.loader (D:\HBuliderW\LuzhuaAPP\node_modules\@dcloudio\vue-cli-plugin-uni\packages\sass-loader\dist\index.js:36:28)

  "dependencies": {  
    "@dcloudio/uni-app-plus": "^2.0.0-alpha-33020211130001",  
    "@dcloudio/uni-h5": "^2.0.0-alpha-33020211130001",  
    "@dcloudio/uni-helper-json": "*",  
    "@dcloudio/uni-i18n": "^2.0.0-alpha-33020211130001",  
    "@dcloudio/uni-mp-360": "^2.0.0-alpha-33020211130001",  
    "@dcloudio/uni-mp-alipay": "^2.0.0-alpha-33020211130001",  
    "@dcloudio/uni-mp-baidu": "^2.0.0-alpha-33020211130001",  
    "@dcloudio/uni-mp-kuaishou": "^2.0.0-alpha-33020211130001",  
    "@dcloudio/uni-mp-qq": "^2.0.0-alpha-33020211130001",  
    "@dcloudio/uni-mp-toutiao": "^2.0.0-alpha-33020211130001",  
    "@dcloudio/uni-mp-vue": "^2.0.0-alpha-33020211130001",  
    "@dcloudio/uni-mp-weixin": "^2.0.0-alpha-33020211130001",  
    "@dcloudio/uni-quickapp-native": "^2.0.0-alpha-33020211130001",  
    "@dcloudio/uni-quickapp-webview": "^2.0.0-alpha-33020211130001",  
    "@dcloudio/uni-stat": "^2.0.0-v3-24020191018001",  
    "@vue/shared": "^3.2.27",  
    "core-js": "^3.20.3",  
    "flyio": "^0.6.2",  
    "mescroll-uni": "^1.3.7",  
    "regenerator-runtime": "^0.12.1",  
    "sass": "^1.26.11",  
    "sass-loader": "^7.3.1",  
    "uview-ui": "^1.8.5",  
    "vue": "^2.6.11",  
    "vuex": "^3.2.0"  
  },
2022-01-18 19:37 负责人:无 分享
已邀请:
我是纸飞机

我是纸飞机

楼主解决了吗?,我也遇到这个问题了

  • 越王够贱 (作者)

    没有 我新建了个项目把代码复制过去才好

    2022-07-15 09:29

要回复问题请先登录注册