wen如故i
wen如故i
  • 发布:2017-04-23 10:29
  • 更新:2020-06-29 17:27
  • 阅读:3732

hbuilder支持es6编写、提示、高亮?编译能通过了吗? 10 分感谢

分类:HBuilder

1、第一次写app,用的原生+mui,什么jq,zpteo,vue都没用,不能与时俱进啊。打算先用用es6爽爽,出了es6都一两年了,没用过,实在说不过去。
2、hbuilder还是挺好用的,对于懒人来说。

2017-04-23 10:29 负责人:无 分享
已邀请:

最佳回复

DCloud_heavensoft

DCloud_heavensoft

HBuilder已经支持es6提示。不过注意运行在手机的话,建议编译成普通js,低端手机对es6支持不完善。

然后推荐使用hbuilderx。老hbuilder以后只修严重bug,不更新功能了。

如使用HBuilderX后,es6着色异常,请在编辑器右下角,选择 javascript(es6+)

pythonv@126.com

pythonv@126.com

现在的版本还是不支持es6,写let都报错,哪怕在项目属性里设置了js为es6

  • 所谓

    是的呀,到底怎么玩的呀,javascript 已经设置成6的版本了

    2018-01-19 16:57

  • 18768156@qq.com

    是 的,写个LET都出错,SE6什么时候才能完全支持呢

    2018-05-14 19:10

  • DCloud_heavensoft

    请升级hbuilderx

    2018-06-20 16:36

wen如故i

wen如故i (作者)

还有些问题,目前是没有用webpack和gulp之类的工具。。。用webpack,,真机调试没什么问题吧。
生成安装包呢?

加班快乐

加班快乐

hbuilder支持es6,但是手机app不支持啊。除非你用插件将es6转为es5(babel)

要回复问题请先登录注册